• Welcome to Theos PowerBasic Museum 2017.

CSED associated with .BAS issue.

Started by Andrea Mariani, February 09, 2014, 03:09:10 PM

Previous topic - Next topic

0 Members and 1 Guest are viewing this topic.

Andrea Mariani


I have associated CSED with .BAS and .INC, using the included option under Options.

Now, when I Double Click a .BAS, it does not recognise the Long File name, but uses the ?????~1.bas  ::)

But if I grab the .BAS icon and drop it in CSED, it accepts the long file names.

What can I do to fix this? (Windows 8.1)

Pierre Bellisle

Hi Andrea,

File association is made from some HKEY_CLASSES_ROOT registry setting.
In those settings %1 is used for short filename and %L is used for long filename.

I did a search for %1 in CSed source files and found it in CSEd_File.inc.

The following should do...

Edit CSEd_File.inc and replace
KeyValue = EXE.FULL$ & " %1"
KeyValue = EXE.FULL$ & $SPC & $DQ & "%L" & $DQ REM %L for long filename
Recompile CSEd.bas and redo the file association.

If curious, to see how command line is processed one could have a look at CSED_ProcessCommandLine sub in CSEd.bas.